Craftum — конструктор сайтов
Создайте сайт с помощью профессиональных шаблонов или придумайте дизайн с нуля

Как изменить положительные числа на отрицательные в Microsoft Excel

Обсудить
Как изменить положительные числа на отрицательные в Microsoft Excel

При некоторых расчетах в электронных таблицах Microsoft Excel получается так, что отрицательные числа становятся положительными или положительные отрицательными, что нужно изменить, нормализовав тем самым отображение содержимого.

Я представлю два метода, выполняющих перевод значений в ячейках, а вы выберите тот, который придется по душе.

Способ 1: Формула + вспомогательный столбец

Этот метод хорош тем, что не требует ручной манипуляции со специальными вставками, о которых пойдет речь в следующем варианте. Однако придется использовать формулу, чтобы достичь желаемого результата. Дело в том, что если просто умножить ячейки на -1, а затем перенести их, в пустых клетках появится 0

Умножение на -1 для изменения знаков чисел в Microsoft Excel

Если же пустых клеток у вас нет, просто умножьте значение на -1 во вспомогательным столбце, растяните формулу, а затем перенесите ее так, как это будет показано в конце следующей инструкции.

Что касается создания функции, то в этом случае идеальным вариантом будет ЕСЛИ, чтобы исключить пустые ячейки. Давайте более детально разберемся с ее созданием и настройкой вспомогательного столбца.

  1. Напротив текущей таблицы в пустой клетке введите =ЕСЛИ(), объявив тем самым интересующую нас функцию.Начало записи формулы для изменения знаков чисел в Microsoft Excel

  2. Затем впишите условие A1<>"". Это означает, что действие нужно выполнить, когда в ячейке нет пустоты.Вторая часть формулы для изменения знаков чисел в Microsoft Excel

  3. После этого введите само действие, то есть умножьте ячейку на -1, записав это как A1*-1;. После единицы обязательно поставьте точку с запятой.Ввод значения для формулы для изменения знаков чисел в Microsoft Excel

  4. Если же условие не удовлетворяется, то есть ячейка пустая, ее нужно оставить пустой. Укажите это в формуле как "".Завершение записи функции для изменения знаков чисел в Microsoft Excel

  5. Нажмите Enter и ознакомьтесь с результатом. Вы видите, что получили значение без минуса или с ним, в зависимости от изначального числа.Результат записи функции для изменения знаков чисел в Microsoft Excel

  6. Растяните функцию на необходимое число клеток в сторону и вниз, чтобы покрыть все ячейки таблицы, после чего скопируйте ее, нажав сочетание клавиш Ctrl + C.Растягивание функции для изменения знаков чисел в Microsoft Excel

  7. Щелкните правой кнопкой мыши по первому значению изначальной таблицы и из контекстного меню выберите параметр вставки «Значение». Иконку вы видите на следующем скриншоте.Специальная вставка функции для изменения знаков чисел в Microsoft Excel

  8. Как видно, вставка прошла успешно – теперь вспомогательный столбец можно удалить, что никак не повлияет на отображение оригинальных чисел.Успешная вставка функции для изменения знаков чисел в Microsoft Excel

Внимательно ознакомьтесь со скриншотами, и у вас все получится! Если хотите, просто вставьте готовую формулу, заменив номер ячейки на свой. Выглядит она так: =ЕСЛИ(A1<>"";A1*-1;"").

Способ 2: Умножение на значение

Данный метод тоже подразумевает умножение ячейки на -1, чтобы убрать отрицательное или положительное значение. Однако в этом случае вспомогательный столбец не понадобится. Вся сложность заключается лишь в том, чтобы отделить пустые ячейки, о чем вы и узнаете в следующей инструкции.

  1. В любой пустой ячейке напишите -1, затем скопируйте ее (именно ячейку, а не значение).Написание числа -1 в ячейке для изменения знаков чисел в Microsoft Excel

  2. Выделите таблицу с данными и нажмите Ctrl + G для вызова необходимого меню.Выделение всех ячеек для изменения знаков чисел в Microsoft Excel

  3. В окне «Переход» кликните по кнопке «Выделить».Переход в окно Выделить для изменения знаков чисел в Microsoft Excel

  4. Отметьте маркером пункт «Константы» и примените изменения.Выбор варианта Константы для изменения знаков чисел в Microsoft Excel

  5. Сейчас вы снимаете выделение с тех ячеек, в которых ничего не содержится, что и видно на скриншоте ниже.Проверка выделения значений для изменения знаков чисел в Microsoft Excel

  6. Остается кликнуть по любой ячейке ПКМ и выбрать пункт «Специальная вставка».Переход к специальной вставке для изменения знаков чисел в Microsoft Excel

  7. В блоке «Вставить» отметьте маркером «Значения».Выбор вставки значения для изменения знаков чисел в Microsoft Excel

  8. После этого укажите операцию «Умножить». Вы уже поняли, что таким образом число -1, скопированное ранее, умножится на все значения в выделенных ячейках.Умножение значения для изменения знаков чисел в Microsoft Excel

  9. После нажатия на «ОК» в окне вы увидите, что изменения вступили в силу, а в пустых ячейках 0 не появился.Проверка результата вставки для изменения знаков чисел в Microsoft Excel

Два этих метода крайне просты в реализации. Используйте любой из них на ваше усмотрение, результат будет одинаковым.

Комментарии

С помощью соцсетей
У меня нет аккаунта Зарегистрироваться
Нажимая кнопку «Зарегистрироваться», я даю согласие на обработку своих персональных данных, указанных в форме регистрации.
С помощью соцсетей
У меня уже есть аккаунт Войти
Нажимая кнопку «Зарегистрироваться», я даю согласие на обработку своих персональных данных, указанных в форме регистрации.
Инструкции по восстановлению пароля высланы на Ваш адрес электронной почты.
Пожалуйста, укажите email вашего аккаунта
Ваш баланс 10 ТК
1 ТК = 1 ₽
О том, как заработать и потратить Таймкарму, читайте в этой статье
Чтобы потратить Таймкарму, зарегистрируйтесь на нашем сайте