3 ответа

HARDKOD
19.01.2017 13:05

Святослав, для диагностики нужно хотя бы понимать: сообщения из логов, какая у вас CMS или фреймворк, видеть код реализующий авторизацию или ссылку на готовый модуль (если нашли таковой). На 99% уверен, что проблема в версии PHP, тк изменения между 5.1 и 5.6 достаточно существенные, чтобы программа перестала работать.

Ссылка на готовый модуль уже была указана. Продублирую: https://github.com/iignatov/LightOpenID
Касательно версии php: на версии 5.3 также ничего не работает.

HARDKOD
19.01.2017 17:58

Если быть точным, это не модуль, а библиотека, которой как раз полагается стать частью модуля для вашего проекта. Как раз под него я и подумал нужна версия PHP 5.1, а теперь вижу что это требования библиотеки, но важный момент, что в требованиях ОТ 5.1 и выше. Скорее всего ошибка в коде использующем эту библиотеку, он и нужен для анализа, если это возможно, но лучше (из соображений безопасности) наверное на почту hello@hardkod.ru