5 ответов

Обновить нужно 2.5 до 3.x.? Обновить можно но много нюансов. Нужно чтоб шаблон сайта поддерживал 3, расширения, модули плагины, а то после обновления могут возникнуть проблемы. А так много статей написано на эту тему.
Только перед всеми манипуляциями не забудьте сделать бэкап и на всякий случай скачать его на пк а не оставлять на хостинге.

Согласен с Николаем. Лишь дополню, что если сайт очень сильно загружен сторонними разрешениями или самописными, то без ошибок и проблем тут не обойтись. На моей практике пока не было ни одного случая, чтобы сайты Joomla 2.5 и ниже с первого раза успешно и без ошибок обновились до актуальной версии.

Пишите на почту: ivanov@podpor.ru .
Проблему решим!

Лавр Иванов
19.12.2016 16:39

Для начала стоит сделать бекап. Вручную, самостоятельно.
Чтобы был.

Далее я бы отключил все расширения, переключился на начальную тему и инициировал процедуру обновления. После обновления стоит сменить тему на основную, поочередно подключать плагины. По ходу стоит смотреть в лог ошибок.

Asylum
19.12.2016 20:14
Студия Восемь-Бит

Зачастую быстрее сверстать новый шаблон, чем «пилить» старый. К тому же шаблоны 2.5, как правило, не адаптивны, а мобильная версия в наше время просто необходима. По личной статистике, более 30% посетителей заходит через мобильные устройства, возможно через пару лет они начнут обгонять посетителей с ПК