7 ответов

Fe0fan_1981
27.06.2016 11:15

Чаще всего у меня такая проблема была когда я указывал в конфиге ошибочные параметры имени пользователя базы. После обращения в поддержку мне подсказали что имя пользователя базы данных и имя базы идентичны на Timeweb. Проверьте, может помочь...

В моем случае я использую Joomla, у меня просто в файле configuration.php стояло ошибочное имя пользователя или базы, уже не вспомнить. На крайний случай, если вдруг не поможет, попробуйте в панели управления указать для базы именно тот пароль, который указан в конфиге вашего сайта...

не помогло все то же самое

Fe0fan_1981
27.06.2016 12:07

Скиньте данные из конфига вашего сайта сюда, посмотрим что там не так.
Строку с паролем можете вырезать, обычно обозначается значением pass/password.

Кстати, вы на текущий момент уверены что пароль в конфиге и пароль от базы совпадают?

Да уверен, что пароли совпадают. Потому что проблема уже пару дней. Вчера я ничего не делал, сегодня начал.

<?php
class JConfig {
public $offline = '0';
public $offline_message = 'Сайт закрыт на техническое обслуживание.<br /> Пожалуйста, зайдите позже.';
public $display_offline_message = '1';
public $offline_image = '';
public $sitename = 'Магазин "Мастер Кровли"';
public $editor = 'tinymce';
public $captcha = 'recaptcha';
public $list_limit = '20';
public $access = '1';
public $debug = '0';
public $debug_lang = '0';
public $dbtype = 'mysql';
public $host = 'localhost';
public $user = 'roofhouse';

public $db = 'roofhouse_site';
public $dbprefix = 'nlkhg_';
public $live_site = '';
public $secret = 'ruobQhalMQCQqk9f';
public $gzip = '0';
public $error_reporting = 'default';
public $helpurl = 'http://help.joomla.org/proxy/index.php?option=com_help&;keyref=Help{major}{minor}:{keyref}';
public $ftp_host = '127.0.0.1';
public $ftp_port = '21';
public $ftp_user = '';
public $ftp_pass = '';
public $ftp_root = '';
public $ftp_enable = '0';
public $offset = 'Europe/Moscow';
public $offset_user = 'UTC';
public $mailer = 'mail';
public $mailfrom = 'braas@inbox.ru';;
public $fromname = 'магазин "Мастер Кровли"';
public $sendmail = '/usr/sbin/sendmail';
public $smtpauth = '0';
public $smtpuser = '';
public $smtppass = '';
public $smtphost = 'localhost';
public $smtpsecure = 'none';
public $smtpport = '25';
public $caching = '0';
public $cache_handler = 'file';
public $cachetime = '15';
public $MetaDesc = '';
public $MetaKeys = '';
public $MetaTitle = '1';
public $MetaAuthor = '1';
public $robots = '';
public $sef = '1';
public $sef_rewrite = '1';
public $sef_suffix = '1';
public $unicodeslugs = '0';
public $feed_limit = '10';
public $log_path = '/home/r/roofhouse/public_html/logs';
public $tmp_path = '/home/r/roofhouse/public_html/tmp';
public $lifetime = '15';
public $session_handler = 'database';
public $MetaRights = '';
public $MetaVersion = '0';
public $sitename_pagetitles = '0';
public $force_ssl = '0';
public $feed_email = 'author';
public $cookie_domain = '';
public $cookie_path = '';
}

Fe0fan_1981
27.06.2016 12:18

Ага, похоже на configuration.php. CMS Joomla, значит.
Вижу первую ошибку, обращаю на нее ваше внимание:
public $user = 'roofhouse';
public $db = 'roofhouse_site';

Помните я раньше упоминал что имя пользователя базы и имя базы данных на Timeweb должны быть идентичны? А у вас отличаются. Попробуйте в качестве значения $user указать roofhouse_site.

Если не поможет, зайдите в панель управления в меню Базы данных MySQL, там напротив localhost шестеренка есть. Нажмите и замените пароль на тот, который в базе данных у вас указан... по моим прикидкам должно помочь.

Проблема больше была в том, что я вообще ничего переписать не мог, потому что Атрибут был 444, а не 644. Но поменял как Вы сказали и все получилось. Спасибо.

Fe0fan_1981
27.06.2016 12:26

Круто, удачи! Заглядывайте сюда если что :)