Amigo
QIWI Ltd., Team lead
6
439
Поделиться:
Amigo
6
439
Поделиться:

6 ответов

Asylum
28.08.2017 11:20

Список сайтов - настройка (вроде символ шестерни) выбрать версию PHP

Amigo
28.08.2017 11:55
QIWI Ltd., Team lead

Это для fpm.
А для cli вообще 5.3 по дефолту. Нашёл в faq правильный путь до 7.0 (/opt/...). Есть даже папка с 7.1, но там какие-то попытки и остатки от 7.1.

Amigo
28.08.2017 15:31
QIWI Ltd., Team lead

Я же написал, что эта настройка применяется для fpm модуля php.
Для CLI режима PHP (запуск php скриптов в консоли) эта настройка не работает и надо запускать скрипты через полный путь до соответствующей версии. Это "/opt/..."
Там есть папка с php7.1 в которой кроме одного файла extension (.so) ничего больше нет. Видимо когда-то админы ставили пыху 7.1, но выпилили обратно оставив мусор.

Alexey Zhukov
07.09.2017 15:16
Moscow, WebMaster

На хостинге никак не поставите (are you root?). Только администратор сервера может это сделать (или не сделать). На хосте находятся другие юзеры. Попробуйте VDS или выделенный сервер, тогда у Вас будет возможность управлять сервером в любом направлении (root permissions).

Amigo
07.09.2017 15:23
QIWI Ltd., Team lead

Это я всё знаю. Благодарю)